juju gomaasapi: got error back from server: 504 Gateway Timeout

Tags:

Answer: 1

6 hours ago

juju bootstrap error

    juju bootstrap --debug --> Fails 
    but
    juju bootstrap --upload-tools --debug  --> Success

    juju bootstrap --debug ----Error below

    Error 1:gomaasapi: got error back from server: 504 Gateway Timeout
    The system cannot communicate with the external server ( 170.x.x.x ).  

Note: 170.x.x.x is eth0 non PXE interface (This is where internet is) ....eth1 is 10.x.x.x network ..PXE boot interface..

     Error 2: The Internet server may be busy, may be permanently down, or may be
    unreachable because of network problems

   environment.yaml Proxy defined under openstack and maas....as well defined in different combinations ie defined under openstack only or maas only or both

    openstack:
     type:  openstack
        juju set-env http-proxy: http://x.x.x.x:80
        juju set-env https-proxy: http://x.x.x.x:80
        juju set-env no-proxy: localhost,10.1.1.0/24,170.x.x.x/26
    Also under 
      maas:
          type:maas
          juju set-env http-proxy: http://x.x.x.x:80
          juju set-env https-proxy: http://x.x.x.x:80
          juju set-env no-proxy: localhost,10.1.1.0/24,170.x.x.x/26
Also http, https and no proxy define in env ie export http_proxy etc

tail -f   /var/log/maas/regiond.log

    Error:3 
    2016-05-09 13:19:01 [-] 127.0.0.1 - - [09/May/2016:20:19:01 +0000] "GET   /MAAS/rpc/ HTTP/1.1" 200 388 "-"  "provisioningserver.rpc.clusterservice.ClusterClientService"
    2016-05-09 13:19:05 [HTTPChannel,14,127.0.0.1] Opening connection with  IPv4Address(TCP, '127.0.0.1', 56410)
    2016-05-09 13:19:05 [-] Closing connection:  (u'Failed to authenticate user.')
    2016-05-09 13:19:11 [HTTPChannel,15,127.0.0.1] Opening connection with IPv4Address(TCP, '127.0.0.1', 56414)
    2016-05-09 13:19:11 [-] Closing connection:  (u'Failed to authenticate user.')
    2016-05-09 13:19:17 [HTTPChannel,16,127.0.0.1] Opening connection with IPv4Address(TCP, '127.0.0.1', 56418)
    2016-05-09 13:19:17 [-] Closing connection:  (u'Failed to authenticate user.')

Answer: 2

30 hours ago

If upload-tools works and it doesn't without, chances are you need the following firewall ports open:

MAAS, its nodes and the Autopilot will need to be able to reach the internet, or at least these sites (http and https):

  • maas.ubuntu.com
  • cloud-images.ubuntu.com
  • streams.canonical.com
  • an Ubuntu archive (archive.ubuntu.com or a mirror)
  • api.jujucharms.com
  • manage.jujucharms.com
  • jujucharms.com
  • store.juju.ubuntu.com
  • keyserver.ubuntu.com
  • ppa.launchpad.net
  • usn.ubuntu.com

If opening holes in a firewall, be mindful that these addresses may resolve to multiple IPs.

Added by: Owen Ankunding

Popular Search

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 1 2 3 4 5 6 7 8 9