Debian package builds in my computer, but fails to build in Launchpad and pbuilder - "msgfmt: cannot locate ITS rules"

Tags:

Answer: 1

18 hours ago

I made a debian package for Blanket, and tried to build it with Launchpad recipe.

While it builds successfully in my computer (Xubuntu 20.04), it fails to build for focal in Launchpad. Here is the relevant part of the buildlog.

Found ninja-1.10.0 at /usr/bin/ninja
   dh_auto_build
    cd obj-x86_64-linux-gnu && LC_ALL=C.UTF-8 ninja -j4 -v
[1/3] glib-compile-resources ../data/resources/blanket.gresource.xml --sourcedir ../data/resources --internal --generate --target data/resources/blanket.gresource --dependency-file data/resources/blanket.gresource.d
xml-stripblanks preprocessing requested, but XMLLINT is not set, and xmllint is not in PATH
[2/3] /usr/bin/meson --internal msgfmthelper ../data/com.rafaelmardojai.Blanket.metainfo.xml.in data/com.rafaelmardojai.Blanket.metainfo.xml xml ../data/../po
FAILED: data/com.rafaelmardojai.Blanket.metainfo.xml 
/usr/bin/meson --internal msgfmthelper ../data/com.rafaelmardojai.Blanket.metainfo.xml.in data/com.rafaelmardojai.Blanket.metainfo.xml xml ../data/../po
msgfmt: cannot locate ITS rules for ../data/com.rafaelmardojai.Blanket.metainfo.xml.in
[3/3] /usr/bin/meson --internal msgfmthelper ../data/com.rafaelmardojai.Blanket.desktop.in data/com.rafaelmardojai.Blanket.desktop desktop ../data/../po
ninja: build stopped: subcommand failed.

In my computer (when I run debuild), the relevant part of the output is

Found ninja-1.10.0 at /usr/bin/ninja
   dh_auto_build
    cd obj-x86_64-linux-gnu && LC_ALL=C.UTF-8 ninja -j4 -v
[1/3] glib-compile-resources ../data/resources/blanket.gresource.xml --sourcedir ../data/resources --internal --generate --target data/resources/blanket.gresource --dependency-file data/resources/blanket.gresource.d
xml-stripblanks preprocessing requested, but XMLLINT is not set, and xmllint is not in PATH
[2/3] /usr/bin/meson --internal msgfmthelper ../data/com.rafaelmardojai.Blanket.desktop.in data/com.rafaelmardojai.Blanket.desktop desktop ../data/../po
[3/3] /usr/bin/meson --internal msgfmthelper ../data/com.rafaelmardojai.Blanket.metainfo.xml.in data/com.rafaelmardojai.Blanket.metainfo.xml xml ../data/../po
   dh_auto_test
    cd obj-x86_64-linux-gnu && LC_ALL=C.UTF-8 MESON_TESTTHREADS=4 ninja test
[0/1] Running all tests.
1/2 Validate desktop file                   OK       0.01 s 
2/2 Validate schema file                    OK       0.01 s 

Ok:                    2

and the build continues successfully. As suggested by this, I added libappstream-glib-dev to the build-depends field, but that did not work.

I am getting the same error inside a pbuilder chroot environment. Am I missing some build dependency when I build it in Launchpad?

Added by: Brain Howe

Answer: 2

33 hours ago

The missing build dependency was appstream (not libappstream-glib-dev)

Thanks to Colin Watson, who provided this information in Launchpad.

Popular Search

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 1 2 3 4 5 6 7 8 9