Skype stops sending and receiving chat messages after 10+ mins into the chat/login

Tags:

Answer: 1

13 hours ago

I am using 11.10+unity. I use Skype (version 2.2.0.35) for office communication. After some time into the chat, Skype does not send or receive any chat messages. Although the chat is on, and other people are chatting. After sudo killall -9 skype I restart it I get all the messages, even from the chat I have missed with Skype on earlier. I do not see any notification updates either.

After some time (probably 5 mins or so) this happens again, and I have to restart Skype. I now see updated notification for missed chats also.

Is there a solution for this?

Added by: Jameson Cummerata

Answer: 2

3 hours ago

I have this problem on 11.04 and 11.10.

As far as I can see, what happens is that PulseAudio dies, and then the next time Skype tries to play a sound (to notify about an incoming/outgoing message), it blocks. And then does nothing. The user interface is responsive, but the background thread that does the actual network communication (and plays sounds) is stopped and will not restart.

PulseAudio restarts automatically, but Skype isn't smart enough to notice that and reconnect to PulseAudio.

The only way to make it work is to killall -9 skype and restart.

The easiest way to identify the issue is to notice that the timestamp of your outgoing messages stops advancing and always shows the same second.

As a workaround I went to Skype's configuration and disabled all sound notifications. Now it never hangs. But I miss incoming calls if I'm not paying attention to the visual notifications.

Added by: Brenna Keebler

Popular Search

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 1 2 3 4 5 6 7 8 9