ibus 1.4.1 doesn't work with Opera 12

Tags:

Answer: 1

35 hours ago

Environment: Ubuntu 12.04 Opera 12 ibus 1.4.1

I've installed ibus-qt and add the two lines below in /usr/bin/opera, but it makes no difference:

QT_IM_MODULE=xim
XMODIFIERS="@im=ibus"

As some say that QT has been deprecated in Opera, so I've also added GTK_IM_MODULE=xim in Opera, but still no difference.

Am I missing something or we just can't use ibus in Opera 12?

Added by: Sabina Russel

Answer: 2

4 hours ago

OK,now I figure it out... It turns out that I need to start ibus with parameter -x so that XIM starts up. I added these lines to ~/.bashrc:

export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export XIM=ibus
export QT_IM_MODULE=ibus
export XIM_ARGS="ibus-daemon -d -x"

Then I modified the startup applications, ibus-daemon -dxr The last step, modify the /usr/bin/opera, add

GTK_IM_MODULE=xim
QT_IM_MODULE=xim
XMODIFIERS="@im=ibus"

It works like a charm... This might be a piece of cake for many users but I think it can help a lot of newbies like me:)

Added by: Octavia Fadel II

Popular Search

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 1 2 3 4 5 6 7 8 9