AMD Ryzen 5 3500U laptop problem and silly solution

Tags:

Answer: 1

29 hours ago

I bought HP Pavilion Ryzen Laptop just to find out on net that HP laptops have huge problems with Linux. I couldn't help it. It was affordable ;-)

Here is the story. In first attempted to install KUbuntu normally from live installation and when first dialog appears it only got top bar painted. No mouse cursor, no window. Nothing. Just top bar. Well. KUbuntu also has minimal graphics installation where installation went smooth.

After reboot. Booting takes more than a minute (it has NVMe disk so it should boot in seconds) and I get normal KUbuntu login screen. But no mouse cursor. I login and what I get is blank screen with some shadows indicating desktop elements. I eventually find out that I can run console by selecting Alt+F2 and type in kconsole. Even network worked. So I was able to install latest drivers from ppa:oibaf/graphics-drivers. Which didn't help at all.

But after some time of frustration I found out this solution. I press ctrl+alt+delete wait for a second and then press Enter (basically I do desktop logout) and then miraculously mouse pointer and login screen appears. I log in and everything works as expected. For two days now.

There has to be a simpler solution to this problem. I am adding amdgpu part of dmesg output at the end.

by TheR


[    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-5.4.0-39-generic root=UUID=370b8653-d0d9-49de-b54b-c30b76f18f62 ro quiet splash amdgpu.gpu_recovery=1 vt.handoff=7
[    0.029824] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.4.0-39-generic root=UUID=370b8653-d0d9-49de-b54b-c30b76f18f62 ro quiet splash amdgpu.gpu_recovery=1 vt.handoff=7
[    2.642911] [drm] amdgpu kernel modesetting enabled.
[    2.643289] amdgpu 0000:04:00.0: remove_conflicting_pci_framebuffers: bar 0: 0xe0000000 -> 0xefffffff
[    2.643291] amdgpu 0000:04:00.0: remove_conflicting_pci_framebuffers: bar 2: 0xf0000000 -> 0xf01fffff
[    2.643292] amdgpu 0000:04:00.0: remove_conflicting_pci_framebuffers: bar 5: 0xfe700000 -> 0xfe77ffff
[    2.643296] fb0: switching to amdgpudrmfb from EFI VGA
[    2.643393] amdgpu 0000:04:00.0: vgaarb: deactivate vga console
[    2.643450] amdgpu 0000:04:00.0: enabling device (0006 -> 0007)
[    2.704244] amdgpu 0000:04:00.0: VRAM: 2048M 0x000000F400000000 - 0x000000F47FFFFFFF (2048M used)
[    2.704246] amdgpu 0000:04:00.0: GART: 1024M 0x0000000000000000 - 0x000000003FFFFFFF
[    2.704249] amdgpu 0000:04:00.0: AGP: 267419648M 0x000000F800000000 - 0x0000FFFFFFFFFFFF
[    2.704552] [drm] amdgpu: 2048M of VRAM memory ready
[    2.704556] [drm] amdgpu: 3072M of GTT memory ready.
[    2.708104] amdgpu: [powerplay] hwmgr_sw_init smu backed is smu10_smu
[    3.000661] fbcon: amdgpudrmfb (fb0) is primary device
[    3.000665] amdgpu 0000:04:00.0: fb0: amdgpudrmfb frame buffer device
[    3.023816] amdgpu 0000:04:00.0: ring gfx uses VM inv eng 0 on hub 0
[    3.023820] amdgpu 0000:04:00.0: ring comp_1.0.0 uses VM inv eng 1 on hub 0
[    3.023823] amdgpu 0000:04:00.0: ring comp_1.1.0 uses VM inv eng 4 on hub 0
[    3.023825] amdgpu 0000:04:00.0: ring comp_1.2.0 uses VM inv eng 5 on hub 0
[    3.023828] amdgpu 0000:04:00.0: ring comp_1.3.0 uses VM inv eng 6 on hub 0
[    3.023830] amdgpu 0000:04:00.0: ring comp_1.0.1 uses VM inv eng 7 on hub 0
[    3.023832] amdgpu 0000:04:00.0: ring comp_1.1.1 uses VM inv eng 8 on hub 0
[    3.023834] amdgpu 0000:04:00.0: ring comp_1.2.1 uses VM inv eng 9 on hub 0
[    3.023837] amdgpu 0000:04:00.0: ring comp_1.3.1 uses VM inv eng 10 on hub 0
[    3.023839] amdgpu 0000:04:00.0: ring kiq_2.1.0 uses VM inv eng 11 on hub 0
[    3.023841] amdgpu 0000:04:00.0: ring sdma0 uses VM inv eng 0 on hub 1
[    3.023844] amdgpu 0000:04:00.0: ring vcn_dec uses VM inv eng 1 on hub 1
[    3.023846] amdgpu 0000:04:00.0: ring vcn_enc0 uses VM inv eng 4 on hub 1
[    3.023849] amdgpu 0000:04:00.0: ring vcn_enc1 uses VM inv eng 5 on hub 1
[    3.023851] amdgpu 0000:04:00.0: ring vcn_jpeg uses VM inv eng 6 on hub 1
[    4.147919] [drm] Initialized amdgpu 3.35.0 20150101 for 0000:04:00.0 on minor 0
[    9.756356] systemd[1]: Starting Load/Save Screen Backlight Brightness of backlight:amdgpu_bl0...
[    9.771396] systemd[1]: Finished Load/Save Screen Backlight Brightness of backlight:amdgpu_bl0.
[   10.272213] snd_hda_intel 0000:04:00.1: bound 0000:04:00.0 (ops amdgpu_dm_audio_component_bind_ops [amdgpu])
[   22.229504] [drm:amdgpu_job_timedout [amdgpu]] *ERROR* ring gfx timeout, signaled seq=1, emitted seq=3
[   22.229639] [drm:amdgpu_job_timedout [amdgpu]] *ERROR* Process information: process Xorg pid 882 thread Xorg:cs0 pid 886
[   22.229647] amdgpu 0000:04:00.0: GPU reset begin!
[   23.556955] amdgpu 0000:04:00.0: GPU reset succeeded, trying to resume
[   24.257785] amdgpu 0000:04:00.0: ring gfx uses VM inv eng 0 on hub 0
[   24.257788] amdgpu 0000:04:00.0: ring comp_1.0.0 uses VM inv eng 1 on hub 0
[   24.257791] amdgpu 0000:04:00.0: ring comp_1.1.0 uses VM inv eng 4 on hub 0
[   24.257794] amdgpu 0000:04:00.0: ring comp_1.2.0 uses VM inv eng 5 on hub 0
[   24.257796] amdgpu 0000:04:00.0: ring comp_1.3.0 uses VM inv eng 6 on hub 0
[   24.257798] amdgpu 0000:04:00.0: ring comp_1.0.1 uses VM inv eng 7 on hub 0
[   24.257800] amdgpu 0000:04:00.0: ring comp_1.1.1 uses VM inv eng 8 on hub 0
[   24.257803] amdgpu 0000:04:00.0: ring comp_1.2.1 uses VM inv eng 9 on hub 0
[   24.257805] amdgpu 0000:04:00.0: ring comp_1.3.1 uses VM inv eng 10 on hub 0
[   24.257808] amdgpu 0000:04:00.0: ring kiq_2.1.0 uses VM inv eng 11 on hub 0
[   24.257810] amdgpu 0000:04:00.0: ring sdma0 uses VM inv eng 0 on hub 1
[   24.257812] amdgpu 0000:04:00.0: ring vcn_dec uses VM inv eng 1 on hub 1
[   24.257814] amdgpu 0000:04:00.0: ring vcn_enc0 uses VM inv eng 4 on hub 1
[   24.257816] amdgpu 0000:04:00.0: ring vcn_enc1 uses VM inv eng 5 on hub 1
[   24.257818] amdgpu 0000:04:00.0: ring vcn_jpeg uses VM inv eng 6 on hub 1
[   24.269472] Modules linked in: cmac algif_hash algif_skcipher af_alg bnep snd_hda_codec_realtek snd_hda_codec_generic ledtrig_audio snd_hda_codec_hdmi nls_iso8859_1 snd_hda_intel snd_intel_dspcfg snd_hda_codec snd_hda_core snd_hwdep snd_pcm uvcvideo videobuf2_vmalloc snd_seq_midi videobuf2_memops snd_seq_midi_event videobuf2_v4l2 edac_mce_amd btusb snd_rawmidi btrtl rtl8821ce(OE) kvm_amd btbcm ccp videobuf2_common btintel joydev bluetooth videodev input_leds serio_raw hp_wmi snd_seq kvm mc sparse_keymap wmi_bmof ecdh_generic snd_seq_device ecc snd_timer k10temp snd cfg80211 snd_pci_acp3x soundcore hp_accel lis3lv02d input_polldev hp_wireless mac_hid acpi_tad sch_fq_codel parport_pc ppdev lp parport ip_tables x_tables autofs4 crct10dif_pclmul crc32_pclmul ghash_clmulni_intel amdgpu amd_iommu_v2 gpu_sched i2c_algo_bit ttm drm_kms_helper syscopyarea sysfillrect sysimgblt fb_sys_fops aesni_intel nvme crypto_simd cryptd r8169 glue_helper psmouse drm i2c_piix4 i2c_amd_mp2_pci realtek nvme_core
[   24.269601]  amdgpu_device_gpu_recover+0x6cd/0x95a [amdgpu]
[   24.269670]  amdgpu_job_timedout+0x103/0x130 [amdgpu]
[   24.269735] amdgpu 0000:04:00.0: GPU reset(2) succeeded!
[   24.269899] amdgpu 0000:04:00.0: AMD-Vi: Event logged [IO_PAGE_FAULT domain=0x0000 address=0x185b002c0 flags=0x0070]
[   24.269913] amdgpu 0000:04:00.0: AMD-Vi: Event logged [IO_PAGE_FAULT domain=0x0000 address=0x185b40000 flags=0x0070]
[   24.269921] amdgpu 0000:04:00.0: AMD-Vi: Event logged [IO_PAGE_FAULT domain=0x0000 address=0x1859ea0e0 flags=0x0050]
[   24.269929] amdgpu 0000:04:00.0: AMD-Vi: Event logged [IO_PAGE_FAULT domain=0x0000 address=0x1859ea100 flags=0x0050]
[   24.269937] amdgpu 0000:04:00.0: AMD-Vi: Event logged [IO_PAGE_FAULT domain=0x0000 address=0x1859e4600 flags=0x0050]
[   24.269945] amdgpu 0000:04:00.0: AMD-Vi: Event logged [IO_PAGE_FAULT domain=0x0000 address=0x185199660 flags=0x0070]
[   24.269952] amdgpu 0000:04:00.0: AMD-Vi: Event logged [IO_PAGE_FAULT domain=0x0000 address=0x185199660 flags=0x0070]
[   24.269960] amdgpu 0000:04:00.0: AMD-Vi: Event logged [IO_PAGE_FAULT domain=0x0000 address=0x185199660 flags=0x0070]
[   24.269967] amdgpu 0000:04:00.0: AMD-Vi: Event logged [IO_PAGE_FAULT domain=0x0000 address=0x185199660 flags=0x0070]
[   24.269975] amdgpu 0000:04:00.0: AMD-Vi: Event logged [IO_PAGE_FAULT domain=0x0000 address=0x185199660 flags=0x0070]
[   34.507522] [drm:amdgpu_job_timedout [amdgpu]] *ERROR* ring sdma0 timeout, signaled seq=49, emitted seq=51
[   34.507656] [drm:amdgpu_job_timedout [amdgpu]] *ERROR* Process information: process  pid 0 thread  pid 0
[   34.507664] amdgpu 0000:04:00.0: GPU reset begin!
[   34.607457] amdgpu 0000:04:00.0: GPU reset succeeded, trying to resume
[   35.309817] amdgpu 0000:04:00.0: ring gfx uses VM inv eng 0 on hub 0
[   35.309820] amdgpu 0000:04:00.0: ring comp_1.0.0 uses VM inv eng 1 on hub 0
[   35.309823] amdgpu 0000:04:00.0: ring comp_1.1.0 uses VM inv eng 4 on hub 0
[   35.309825] amdgpu 0000:04:00.0: ring comp_1.2.0 uses VM inv eng 5 on hub 0
[   35.309828] amdgpu 0000:04:00.0: ring comp_1.3.0 uses VM inv eng 6 on hub 0
[   35.309830] amdgpu 0000:04:00.0: ring comp_1.0.1 uses VM inv eng 7 on hub 0
[   35.309832] amdgpu 0000:04:00.0: ring comp_1.1.1 uses VM inv eng 8 on hub 0
[   35.309834] amdgpu 0000:04:00.0: ring comp_1.2.1 uses VM inv eng 9 on hub 0
[   35.309837] amdgpu 0000:04:00.0: ring comp_1.3.1 uses VM inv eng 10 on hub 0
[   35.309839] amdgpu 0000:04:00.0: ring kiq_2.1.0 uses VM inv eng 11 on hub 0
[   35.309841] amdgpu 0000:04:00.0: ring sdma0 uses VM inv eng 0 on hub 1
[   35.309844] amdgpu 0000:04:00.0: ring vcn_dec uses VM inv eng 1 on hub 1
[   35.309846] amdgpu 0000:04:00.0: ring vcn_enc0 uses VM inv eng 4 on hub 1
[   35.309848] amdgpu 0000:04:00.0: ring vcn_enc1 uses VM inv eng 5 on hub 1
[   35.309850] amdgpu 0000:04:00.0: ring vcn_jpeg uses VM inv eng 6 on hub 1
[   35.321448] amdgpu 0000:04:00.0: GPU reset(3) succeeded!
[   35.321533] amdgpu 0000:04:00.0: AMD-Vi: Event logged [IO_PAGE_FAULT domain=0x0000 address=0x185b40000 flags=0x0070]
[   35.740563] [drm:amdgpu_cs_ioctl [amdgpu]] *ERROR* Failed to initialize parser -125!
Added by: Brenden Rosenbaum

Answer: 2

11 hours ago

Wll. It turns out, that installing newer kernel on Ubuntu nowadays is not complicated at all. Instructions can be found here: https://linuxconfig.org/how-to-upgrade-kernel-to-latest-version-on-ubuntu-20-04-focal-fossa-linux

So the solution was to install latest kernel. 5.7.6. in my case. Hopefully laptop can be installed normally in Ubuntu 20.10.

There is additional problem. WiFi adapter (rtl8821ce) doesn't have driver included in kernel. Fortunately wired network works so I was able to install WiFi adapter quickly. Instructions: How to install Wi-Fi driver for Realtek RTL8821CE on Ubuntu 18.04?

To summarize my hardware: HP Pavilion Laptop 15-cw1xxx, AMD Ryzen5 3500U, 8GB RAM, 512GB NVMe disk.

Now works on KUbuntu 20.04

by TheR

Popular Search

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 1 2 3 4 5 6 7 8 9