Accessing my Ubuntu 1804 through rdp

Tags:

Answer: 1

6 hours ago

I am trying to access my Ubuntu 18.04.6 LTS from a windows 10 machine using xrdp. Just after I installed xrdp on my Ubuntu, it did work once. But I get a blue screen on my windows machine ever since.

  • the xrdp write in the logs:
    • main log:
jpmena@jpmena-ThinkCentre-M710t:/var/log$ tail -10 xrdp.log 
[20220131-10:23:11] [DEBUG] Closed socket 17 (AF_UNIX)
[20220131-10:23:15] [DEBUG] Closed socket 17 (AF_UNIX)
[20220131-10:23:18] [DEBUG] Closed socket 17 (AF_UNIX)
[20220131-10:23:22] [DEBUG] Closed socket 17 (AF_UNIX)
[20220131-10:23:25] [DEBUG] Closed socket 17 (AF_UNIX)
[20220131-10:23:28] [DEBUG] xrdp_wm_log_msg: connection problem, giving up
[20220131-10:23:28] [DEBUG] Closed socket 17 (AF_UNIX)
[20220131-10:23:28] [DEBUG] xrdp_wm_log_msg: some problem
[20220131-10:23:28] [DEBUG] xrdp_mm_module_cleanup
[20220131-10:23:28] [DEBUG] Closed socket 16 (AF_INET6 ::1 port 59844)
  • other log:
jpmena@jpmena-ThinkCentre-M710t:/var/log$ tail -20 xrdp-sesman.log
[20220131-10:19:55] [DEBUG] Closed socket 9 (AF_INET6 :: port 5910)
[20220131-10:19:55] [DEBUG] Closed socket 9 (AF_INET6 :: port 6010)
[20220131-10:19:56] [DEBUG] Closed socket 9 (AF_INET6 :: port 6210)
[20220131-10:19:56] [INFO ] calling auth_start_session from pid 303
[20220131-10:19:56] [DEBUG] Closed socket 8 (AF_INET6 ::1 port 3350)
[20220131-10:19:56] [DEBUG] Closed socket 7 (AF_INET6 ::1 port 3350)
[20220131-10:19:56] [DEBUG] Closed socket 8 (AF_INET6 ::1 port 3350)
[20220131-10:19:56] [INFO ]  :10 -auth .Xauthority -geometry 1364x768 -depth 24  
[20220131-10:20:06] [ERROR] X server for display 10 startup timeout
[20220131-10:20:06] [ERROR] X server for display 10 startup timeout
[20220131-10:20:06] [CORE ] waiting for window manager (pid 304) to exit
[20220131-10:20:06] [ERROR] another Xserver might already be active on display 10 - see log
[20220131-10:20:06] [DEBUG] aborting connection...
[20220131-10:20:06] [CORE ] window manager (pid 304) did exit, cleaning up session
[20220131-10:20:06] [INFO ] calling auth_stop_session and auth_end from pid 303
[20220131-10:20:06] [DEBUG] cleanup_sockets:
[20220131-10:20:07] [DEBUG] cleanup_sockets: deleting /var/run/xrdp/sockdir/xrdp_chansrv_socket_10
[20220131-10:20:07] [DEBUG] cleanup_sockets: deleting /var/run/xrdp/sockdir/xrdpapi_10
[20220131-10:20:07] [DEBUG] cleanup_sockets: failed to delete /var/run/xrdp/sockdir/xrdpapi_10
[20220131-10:20:07] [INFO ] ++ terminated session:  username jpmena, display :10.0, session_pid 303, ip ::ffff:10.156.6.87:64996 - socket: 12
  • I searched on google with the terms another Xserver might already be active on display 10 but none of the solution did work for me.

Popular Search

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z 1 2 3 4 5 6 7 8 9